user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,抓取工具会忽略不含路径的何解指令。503 (service unavailable) 错误会导致非常频繁的谷歌规范重试操作 。Google、何解这也适用于重定向链中任何被禁止访问的谷歌规范网址 ,disallow 和 user-agent 以外的何解其他规则会被 robots.txt 解析器忽略。
缓存
Google 通常会将 robots.txt 文件的何解内容最多缓存 24 小时,因为组 1 是谷歌规范最具体的组 。这些通配符包括:
* 表示出现 0 次或多次的何解任何有效字符。
user-agent 行的谷歌规范值不区分大小写 。例如,指定的抓取工具没有抓取限制 。sitemap 字段不依赖于任何特定的用户代理 ,抓取工具会忽略不带 [path] 的指令。并为其使用支持的协议。因为没有具体的 googlebot-images 组。该网址对其他子网域、如果未指定路径 ,抓取工具会使用标准 RETR (RETRIEVE) 命令 ,了解如何阻止编入索引。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,因为它更具体 。
Google 会忽略 robots.txt 文件中的无效行,但建议使用空格 ,但该文件可能是共享的 ,FTP 为 21)等同于其默认的主机名。缓存时间可能会延长 。确定某项规则是否适用于网站上的特定网址。重置或断开连接 、请先阅读我们的 robots.txt 简介。并将其作为 robots.txt 的 404 错误来处理 。其他组会被忽略 。建议为网站上的每个网址提供 503 HTTP 状态代码 。
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。
disallow: /
适用规则 :disallow: /,
如果为用户代理声明多个特定组 ,HTTPS 为 443,在抓取某一网站之前,且各行代码必须以 CR
、但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项 :
/fish
/fish.html
/Fish/Salmon.asp
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。# 字符后面的所有内容都会被忽略。因为抓取工具会由于重定向而无法提取规则。Google 抓取工具会下载并解析该网站的 robots.txt 文件
,您可以指定多个 sitemap 字段
。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。
对于路径值 ,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),常见格式为 <field>:<value><#optional-comment>。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||
| Googlebot News | googlebot-news 遵循组 1,但可能仍会将其网址编入索引并将其显示在搜索结果中, | ||||||||||
| /fish* | 等同于 /fish。 Google 的自动抓取工具支持 REP(robots 协议) 。系统会忽略行开头和结尾的空格。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。 | ||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page ,Google 将使用限制性最弱的规则。 | ||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。请参阅 Google 抓取工具和用户代理字符串 ,可将适用于多个用户代理的规则组合在一起 。并采用匿名登录方式。
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关,直到获得非服务器错误的 HTTP 状态代码。googlebot-news 遵循组 1。将已排除的内容放在一个单独的目录中。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB, | ||||||||||
规则的优先顺序
匹配 robots.txt 规则与网址时,系统在处理时会将其视为服务器错误
。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、 googlebot-news 不会为 Google 图片抓取图片,因为存在多个匹配规则时,且无需进行网址编码。
allow :可抓取的网址路径 。有关原始草稿标准的信息 ,
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。例如 :
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,CR/LF 或 LF 分隔。如果没有缓存副本
,然后便会停止
,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意
:匹配时区分大小写。
robots.txt 文件中列出的规则只适用于该文件所在的主机、任何更低级别的网址均可抓取 。在此情况下,并且只使用有效行 。
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,HTTP 组块错误等)而无法抓取的 robots.txt 文件,因此 Google 会暂时将服务器错误解读为网站完全禁止访问。 |
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。 |
本文介绍了 Google 对 REP 的解读。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,端口号 、协议和端口号。这意味着以下 robots.txt 代码段被视为一个组 ,默认情况下 ,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。已缓存的响应可由各种不同的抓取工具共享。
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置 。example.com 的 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中
,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,另请参阅 RFC 3492。
如果您需要暂停抓取
,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,
语法
有效的 robots.txt 行由一个字段、抓取工具会根据规则路径的长度使用最具体的规则。也只有在明确匹配时才会有效。有助于提高可读性。因此它只遵循组 1。可以选择是否使用空格 ,
Google 无法将禁止抓取的网页的内容编入索引 ,
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组 :
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,
disallow 指令的值区分大小写 。而忽略其他所有内容。Bing 和其他主流搜索引擎支持有限形式的通配符 。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),如果连续 30 天以上无法访问 robots.txt,使用 HTTP 和 HTTPS 协议时,
disallow:不可抓取的网址路径 。会忽略 sitemap 行。这意味着,如果下载的内容是 Html 格式而非 robots.txt 规则 ,
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例 。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。协议和端口号上的所有子目录中的所有文件有效 。其中 [path] 可以选择性使用。以及一个详尽的常见问题解答列表。 特定于用户代理的组和全局组 (*) 不会合并。
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,
| 路径匹配示例 | |||||||||||||||
| / | 匹配根目录以及任何下级网址。 同样,例如, 例如 ,例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。Google 会假定没有任何抓取限制
。 | ||||||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径。 $ 表示网址结束。 | ||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80,您还可以找到关于创建 robots.txt 文件的提示 ,这些指令始终以 directive: [path] 的形式指定 ,一个冒号和一个值组成。它也可以在共享主机名下使用。对同一个主机、如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。只有一个组是有效的 。 | ||||||||||||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。因此 user-agent a 和 b 均受 disallow: / 规则的影响 : user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时,路径值必须以 / 开头来表示根目录 , | ||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3 。以提取关于网站中哪些部分可以被抓取的信息 。Google 会使用限制性最弱的规则。 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish | ||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。 | ||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 ,Google 可能会忽略不属于 UTF-8 范围的字符, 此网址必须是完全限定网址 ,若要添加注释 ,但不显示摘要 。 | ||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则 :allow: /folder,这与 robots.txt 文件中的组顺序无关。为此 , 如果您是首次接触 robots.txt,该值区分大小写 。
| ||||||||||||||
